Saki's 研究记录

Saki's 研究记录

MckeeのClub & SAKI’sブログ

CentOS 更新 Python 版本
刚到手的Centos服务器默认的Python版本是2.7,现在很多新开发的Python均需要3.X以上。下面升级Centos的预装Python版本到最新。 下载Python3.9.512wget https://www.python.org/ftp/python/3.9.5/Python-3.9.5.tgztar zxvf Python-3.9.5.tgz 安装必须的包1dnf -y install gcc libffi-devel 安装1234cd Python-3.9.5/mkdir /usr/local/python3/./configure --prefix=/usr/loc...
解决 Empty reply from server
SSH Key新服务器上git clone自己的项目时报错: 1fatal: unable to access ‘https://github.com/***/***.git/‘: Empty reply from server 检查密匙: 1ls -al ~/.ssh 应该会有一个id_rsa.pub 文件,如果没有,在终端运行ssh-keygen -t rsa以生成之。 打开你的github主页,打开Add SSH key的页面https://github.com/settings/ssh按照2的做法添加密钥最后测试验证: 1ssh -T git@github.com 正常情况下应该...
yum install/update golang
InstallInstall EPEL package by using yum install epel-release command: 1yum install -y epel-release Update your system: 1yum update Install Golang using yum: 1yum install -y golang Check Golang version: 12go versiongo version go1.15.14 linux/amd64 UpdateUnless someone either adds Go 1.7+ to a...
docker-compose 安装
安装1curl -L "https://github.com/docker/compose/releases/download/1.29.2/docker-compose-$(uname -s)-$(uname -m)" -o /usr/local/bin/docker-compose 修改权限1chmod +x /usr/local/bin/docker-compose 验证1docker-compose --version *** 注意 *** 如果提示 docker-compose: command not found, 需要将 /usr/local/bi...
Centos8 安装 Docker 并替换源
零.背景介绍CentOS的服务器刚到手,执行yum install docker -y安装docker,反手一个docker run就报错: 12Emulate Docker CLI using podman. Create /etc/containers/nodocker to quiet msg.Error: open /proc/self/uid_map: no such file or directory 壹.解决办法 卸载服务器上老版本的docker,如果没有安装过执行命令也无妨。 1yum remove docker docker-client docker-client-...
Hello World
Welcome to Hexo! This is your very first post. Check documentation for more info. If you get any problems when using Hexo, you can find the answer in troubleshooting or you can ask me on GitHub. Quick StartCreate a new post1$ hexo new "My New Post" More info: Writing Run server1$ hexo ...